thephpleague / uri Star 1.1k Code Issues Pull requests [READ-ONLY] URI manipulation Library php uri extraction psr-7 expansion rfc-3986 uri-parser rfc-6570 rfc-3987 uri-template parse-url uri-extraction Updated Oct 6, 2026 PHP
thephpleague / uri-parser Star 388 Code Issues Pull requests RFC3986/RFC3987 compliant URI parser url php uri url-standard rfc-3986 uri-parser rfc-3987 Updated May 16, 2021 PHP
thephpleague / uri-schemes Star 211 Code Issues Pull requests Collection of URI Immutable Value Objects php uri rfc-3986 psr7-uri uri-normalize uri-validation psr7-uriinterface rfc-3987 Updated Mar 27, 2021 PHP
thephpleague / uri-manipulations Star 195 Code Issues Pull requests Functions and Middleware to manipulate URI Objects php uri rfc-3986 psr7-uri uri-manipulations uri-normalize uri-resolve uri-relativize uri-formatter rfc-3987 Updated Mar 27, 2021 PHP
coroboros / uri Star 15 Code Issues Pull requests RFC-3986 URI toolkit for Node.js. IDN (RFC-3987), IPv6 zone identifiers (RFC 6874), Sitemap protocol. Zero dependencies. nodejs url sitemap typescript parse uri domain encode ip decode punycode zero-dependency rfc-3986 rfc-1123 rfc-3987 idn rfc-1034 coroboros rfc-6874 sitemap-protocol Updated Sep 6, 2026 TypeScript
swift-ietf / swift-rfc-3987 Star 2 Code Issues Pull requests Swift implementation of RFC 3987: Internationalized Resource Identifiers (IRIs). internationalization uri standards rfc rfc-3987 Updated Sep 30, 2026 Swift
marrus-sh / Eerie Star 0 Code Issues Pull requests 👂👁 A RegExp‐based IRI parser. javascript coffeescript rfc-3987 coffeescript2 rfc3987 Updated Aug 18, 2020 CoffeeScript