Skip to content

hostname_max column is empty #181

Description

@vachanda

Hi,

I'm using pt-query-digest to parse the mysql slow query logs and am trying to visualize the data using anemometer. I run initial DB schema migrations on anemometer, but when I try to run the pt-query-digest command, it fails with the error - DBD::mysql::st execute failed: Column 'hostname_max' cannot be null.

The pt-query-digest command -

pt-query-digest --user=abc --password=abc --database=slow_query_log \
                           --review h=localhost,D=slow_query_log,t=global_query_review \
                           --history h=localhost,D=slow_query_log,t=global_query_review_history \
                           --no-report --limit=0% slow_query.log

I'm running it on mysql version 5.7.12 and percona-toolkit version 2.2.18.
Any ideas on how to fix it?

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions